benoitc avatar

benoitc

Total Packages

72

Total Downloads

1 071 218 249+

Stats

Updated daily
certifi v2.18.0

CA bundle adapted from Mozilla by https://certifi.io

0 20K 40K 60K 80K
179.5M Total
21.8K Yesterday
362.9K Last 7 days
idna v7.1.0

A pure Erlang IDNA implementation

0 20K 40K 60K 80K
177.5M Total
34.2K Yesterday
473.2K Last 7 days
hackney v4.9.1

Simple HTTP client with HTTP/1.1, HTTP/2, and HTTP/3 support

0 20K 40K 60K 80K
174.4M Total
20.2K Yesterday
337.2K Last 7 days

unicode_util compatibility library for Erlang < 20

0 10K 20K 30K 40K
171.8M Total
14.3K Yesterday
242.3K Last 7 days
mimerl v1.5.0

Library to handle mimetypes

0 20K 40K 60K 80K
168.2M Total
19K Yesterday
325.8K Last 7 days
metrics v2.5.0

A generic interface to different metrics systems in Erlang.

0 10K 20K 30K 40K
165.6M Total
12.8K Yesterday
229.1K Last 7 days
lru v2.4.0

implements a fixed-size LRU cache

0 2K 4K 6K 8K
28.3M Total
637 Yesterday
23.4K Last 7 days

A rebar plugin to specify path dependencies.

0 500 1000 1500 2000
1.6M Total
147 Yesterday
3.5K Last 7 days
quic v2.1.3

Pure Erlang QUIC implementation (RFC 9000)

0 5K 10K 15K 20K
1.2M Total
6.3K Yesterday
105.2K Last 7 days
h2 v0.12.5

HTTP/2 protocol library for Erlang

0 5K 10K 15K 20K
1.1M Total
6.2K Yesterday
102.6K Last 7 days

WebTransport protocol for Erlang (HTTP/2 and HTTP/3)

0 5K 10K 15K 20K
1M Total
6.1K Yesterday
98.5K Last 7 days
erl_cidr v1.2.1

CIDR library for Erlang

0 50 100 150 200
349.9K Total
19 Yesterday
608 Last 7 days
rocksdb v3.1.2

RocksDB for Erlang

0 200 400 600 800
261.3K Total
130 Yesterday
1.4K Last 7 days
inet_ext v1.0.0

An IP/Ethernet Utilities library

0 50 100 150 200
136.2K Total
11 Yesterday
132 Last 7 days
hooks v3.0.0

generic plugin & hook system

0 20 40 60 80
47.4K Total
6 Yesterday
144 Last 7 days
snappy v1.1.1

snappy compressor/decompressor Erlang NIF wrapper

0 5 10 15 20
35.9K Total
2 Yesterday
26 Last 7 days
ehash v0.2.1

A library to consistently crypto-hash Erlang Terms

0 50 100 150 200
26.7K Total
15 Yesterday
148 Last 7 days

Erlang CouchDB client

0 20 40 60 80
25.5K Total
6 Yesterday
85 Last 7 days

HTTP/1.1 protocol library for Erlang

0 500 1000 1500 2000
20.3K Total
141 Yesterday
2.5K Last 7 days
ucol v2.0.0

ICU based collation module

0 10 20 30 40
19.4K Total
4 Yesterday
89 Last 7 days
econfig v0.7.3

simple Erlang config handler using INI files

0 50 100 150 200
18.5K Total
10 Yesterday
310 Last 7 days

Fast metrics library for Erlang with Prometheus export and OpenTelemetry support

0 100 200 300 400
15.7K Total
134 Yesterday
1.6K Last 7 days

MCP Protocol Library for Erlang

0 100 200 300 400
12.3K Total
139 Yesterday
1.6K Last 7 days

WebSocket protocol library for Erlang (RFC 6455 / RFC 8441 / RFC 9220)

0 100 200 300 400
10.6K Total
150 Yesterday
1.6K Last 7 days
livery v0.10.7

Livery: a modern Erlang web framework over HTTP/1.1, HTTP/2, and HTTP/3

0 100 200 300 400
10.4K Total
49 Yesterday
1.3K Last 7 days
nat v0.5.2

NAT traversal library for Erlang - UPnP IGD, NAT-PMP, PCP

0 10 20 30 40
10.4K Total
2 Yesterday
6 Last 7 days

Encryption primitives and key providers for Barrel (AES-256-GCM envelope, off...

0 50 100 150 200
8.6K Total
18 Yesterday
281 Last 7 days
hlc v3.0.4

hybrid logical clock

0 50 100 150 200
7K Total
6 Yesterday
182 Last 7 days

A WebAssembly runtime implemented in Erlang/OTP

0 200 400 600 800
6.7K Total
6 Yesterday
681 Last 7 days

Execute Python applications from Erlang using dirty NIFs

0 50 100 150 200
6.7K Total
55 Yesterday
237 Last 7 days

gRPC for Erlang on the livery HTTP/2 stack: server and client

0 100 200 300 400
6.2K Total
44 Yesterday
1.2K Last 7 days

JSON Decoder/Encoder.

0 10 20 30 40
6.1K Total
4 Yesterday
54 Last 7 days

MQTT-style topic matching trie using ETS

0 50 100 150 200
5.8K Total
4 Yesterday
182 Last 7 days

Erlang HTTP client application

0 1 2 3 4
4.7K Total
4 Yesterday
13 Last 7 days
iommap v1.1.3

Memory-mapped file I/O NIF for Erlang

0 20 40 60 80
4.1K Total
2 Yesterday
91 Last 7 days

A rebar3 elixir compiler plugin

0 2 4 6 8
3.9K Total
2 Yesterday
4 Last 7 days

A rebar plugin

0 2 4 6 8
3.8K Total
2 Yesterday
6 Last 7 days

An Erlang OAuth 1.0 implementation

0 2 4 6 8
3.3K Total
4 Yesterday
4 Last 7 days

Erlang document database with MVCC, queries, and replication

0 50 100 150 200
2.8K Total
4 Yesterday
149 Last 7 days
erllama v0.11.0

Native Erlang/OTP wrapper around llama.cpp with token-exact tiered KV cache; ...

0 20 40 60 80
2.4K Total
6 Yesterday
18 Last 7 days

xxHash for Erlang.

0 2 4 6 8
2.2K Total
6 Yesterday
6 Last 7 days
mochicow v0.6.4

mochiweb adapter for cowboy

0 5 10 15 20
2.1K Total
2 Yesterday
2 Last 7 days
ucol_nif v1.1.5

ICU based collation module

0 5 10 15 20
2K Total
2 Yesterday
2 Last 7 days

MochiMedia Web Server

0 2 4 6 8
1.9K Total
4 Yesterday
4 Last 7 days
memstore v0.2.3

Simple memory database for Erlang application using MVCC to store the data.

0 5 10 15 20
1.9K Total
2 Yesterday
2 Last 7 days

PBKDF2 NIF implementation

0 5 10 15 20
1.7K Total
2 Yesterday
2 Last 7 days

Lightweight embedding generation for Erlang

0 20 40 60 80
1.6K Total
6 Yesterday
54 Last 7 days

sortable serialiaation library

0 2 4 6 8
1.6K Total
4 Yesterday
4 Last 7 days
barrel v1.11.1

Barrel: the embeddable edge-AI database composing the document and vector layers

0 20 40 60 80
1.3K Total
4 Yesterday
89 Last 7 days

Embedded Erlang vector database with pluggable backends (HNSW, FAISS) and Roc...

0 20 40 60 80
1.2K Total
6 Yesterday
51 Last 7 days

Multi-protocol server for the barrel edge database (REST/JSON over livery)

0 10 20 30 40
851 Total
4 Yesterday
55 Last 7 days
ets_cas v0.1.1

handle CAS semantic to ETS on different OTP version

0 2 4 6 8
851 Total
4 Yesterday
4 Last 7 days

An S3-compatible object storage client built on the livery client

0 10 20 30 40
770 Total
2 Yesterday
20 Last 7 days
hornbeam v1.4.1

WSGI/ASGI HTTP server powered by the BEAM

0 10 20 30 40
696 Total
2 Yesterday
2 Last 7 days

RocksDB Cloud for Erlang

0 2 4 6 8
616 Total
2 Yesterday
10 Last 7 days
estun v0.1.2

Erlang STUN client for NAT traversal and hole punching

0 5 10 15 20
612 Total
4 Yesterday
5 Last 7 days

Barrel agent layer: spaces (shared context databases), capability tokens, ses...

0 10 20 30 40
600 Total
5 Yesterday
15 Last 7 days

Agent2Agent (A2A) protocol: core objects, client and server

0 10 20 30 40
569 Total
3 Yesterday
64 Last 7 days
duktape v1.1.0

Duktape JavaScript engine for Erlang

0 5 10 15 20
496 Total
3 Yesterday
6 Last 7 days

Cross-encoder reranking for Erlang

0 5 10 15 20
473 Total
3 Yesterday
3 Last 7 days
teleport v0.6.2

application to call remote functions

0 2 4 6 8
472 Total
2 Yesterday
2 Last 7 days

Trigram substring and regex index over barrel_docdb documents

0 10 20 30 40
432 Total
4 Yesterday
55 Last 7 days

Erlang NIF bindings for FAISS vector similarity search

0 5 10 15 20
350 Total
4 Yesterday
4 Last 7 days

Stripe API client built on the livery HTTP client

0 5 10 15 20
348 Total
2 Yesterday
6 Last 7 days
quickjs v0.2.0

QuickJS JavaScript engine for Erlang (powered by quickjs-ng)

0 2 4 6 8
324 Total
2 Yesterday
8 Last 7 days
ebson v0.2.0

High-performance BSON encoder/decoder for Erlang

0 2 4 6 8
281 Total
4 Yesterday
4 Last 7 days

S3-compatible attachment storage backend for barrel_docdb

0 10 20 30 40
246 Total
4 Yesterday
50 Last 7 days
qpack v0.1.0

QPACK header compression for HTTP/3 (RFC 9204)

0 1 2 3 4
181 Total
2 Yesterday
6 Last 7 days
masque v0.7.0

MASQUE: Proxying UDP in HTTP (RFC 9298) for Erlang

0 2 4 6 8
177 Total
2 Yesterday
8 Last 7 days

HyParView peer membership with pluggable Erlang distribution carrier

0 1 2 3 4
174 Total
4 Yesterday
4 Last 7 days

Wasmtime bindings for Erlang: run WebAssembly natively, call Erlang from the ...

0 2 4 6 8
168 Total
6 Yesterday
6 Last 7 days

Agent2Agent (A2A) gRPC binding for livery_grpc

0 1 2 3 4
100 Total
2 Yesterday
6 Last 7 days