ivan-podgurskiy avatar

Ivan Podgurskiy

ivan-podgurskiy

Total Packages

19

Total Downloads

3 528+

Stats

Updated daily

Human-friendly formatting for Elixir: bytes, durations, relative time, large ...

0 2 4 6 8
589 Total
2 Yesterday
17 Last 7 days

RFC 9309 robots.txt (robotstxt) parser and matcher for the Robots Exclusion P...

0 5 10 15 20
342 Total
2 Yesterday
70 Last 7 days

Whitelist-based casting of values to atoms without growing the VM atom table ...

0 2 4 6 8
304 Total
0 Yesterday
8 Last 7 days

POSIX-like shell word splitting, escaping, and joining. An Elixir take on Pyt...

0 2 4 6 8
235 Total
0 Yesterday
8 Last 7 days

Collapse concurrent duplicate Elixir calls into one supervised execution per ...

0 2 4 6 8
215 Total
2 Yesterday
10 Last 7 days
jitter v0.1.0

Backoff jitter strategies (No, Full, Equal, Decorrelated) from Marc Brooker's...

0 1 2 3 4
201 Total
3 Yesterday
11 Last 7 days

Async-safe, process-local freezing of DateTime.utc_now/0 for tests — no beh...

0 1 2 3 4
177 Total
4 Yesterday
8 Last 7 days

Correct gitignore and wildmatch semantics for Elixir.

0 1 2 3 4
168 Total
2 Yesterday
11 Last 7 days

Parse and match .dockerignore files in Elixir with Docker-compatible semantics.

0 1 2 3 4
157 Total
2 Yesterday
13 Last 7 days

RFC 9530 Digest Fields for Elixir: build, parse, and verify Content-Digest, R...

0 1 2 3 4
149 Total
2 Yesterday
12 Last 7 days

RFC 9421 HTTP Message Signatures for Elixir: create and verify signatures ove...

0 1 2 3 4
143 Total
2 Yesterday
8 Last 7 days

Parse, resolve, and serialize Git .mailmap files in Elixir to canonicalize au...

0 2 4 6 8
142 Total
2 Yesterday
10 Last 7 days

EditorConfig Core implementation for Elixir: parser, glob matcher, resolver, ...

0 1 2 3 4
137 Total
2 Yesterday
12 Last 7 days

Validate and canonicalize PEP 639-compatible SPDX license expressions in Elixir.

0 1 2 3 4
107 Total
0 Yesterday
6 Last 7 days
vcf v1.0.0

VCF 4.1–4.5 parser, validator, streaming reader, and writer for Elixir.

0 1 2 3 4
103 Total
0 Yesterday
6 Last 7 days

Parse, serialize, and manipulate Git commit message trailers in Elixir.

0 1 2 3 4
100 Total
2 Yesterday
8 Last 7 days
rxing v0.1.0

Decode barcodes from image binaries with Rust-backed performance.

0 1 2 3 4
100 Total
0 Yesterday
6 Last 7 days

Parse, validate, and serialize RFC 9116 security.txt files in Elixir.

0 1 2 3 4
97 Total
0 Yesterday
6 Last 7 days

Pinned Unicode identifier security properties and policy checks for Elixir.

0 10 20 30 40
62 Total
0 Yesterday
6 Last 7 days